Frequently Asked Questions

AAX plugins v2.5.1 and The Flutes v1.2.2 not recognized in ProTools/Mac
Last Updated 11 months ago

The Saxophones, Clarinets, Double Reed v2.5.1 and The Flutes v1.2.2 in some cases are not recognized in ProTools (both 32 and 64 bit) for Mac.

Please update your product(s).
The latest release is available on the Customer Portal.

Please Wait!

Please wait... it will take a second!